Moderator: jsachs

Posts: 1158
Joined: April 25th, 2009, 12:56 am
What is the make/model of your primary camera?: Fuji X-E2


Post by tomczak »

I don't get it:

I installed PWP6 in a custom folder. It ran fine. Then the next time I tried to run it, probably after rebooting, it gave an error message to a tune: Ltkrn15u.dll is not Windows image file? Then I found all the instances of this .dll on my computer, there were a few identical ones in a few folders (there are a few installations of PWP on this machine) and (sic!) a zero-byte size file in the newest PWP6 folder. I ran the PWP Install again, and 'repaired' the installation, whatever that meant. The file got reinstalled, and the PWP6 started working again.

Now, PWP6 is still working, but the said .dll file became zero-byte sized again! I haven't rebooted the computer yet to see what happens...
Maciej Tomczak
Posts: 304
Joined: April 24th, 2009, 2:07 pm

Re: Ltkrn15u.dll

Post by MarkT »

Not that I can help to understand any of this, but this is my $0.02 worth.

Ltkrn15u.dll shows up in six locations on my drive: one in an Olympus sub-directory and three times in various Canon sub-directories. It appears twice in DL-C sub-directories: one in the Ver 5.0 dir (dated 19/07/2010 468 bytes) and one in the Ver 6.0 dir (dated 29/08/2009 468 bytes). Odd that the file in the Ver 6.0 location is older than the one for Ver 5.0?

No instances of "zero-byte" files though...
Posts: 594
Joined: April 2nd, 2009, 11:58 am

Re: Ltkrn15u.dll

Post by ksinkel »

Ltkrn15u.dll is part of the Leadtools dll suite used to read and write images. These files are a required part of each PWP installation and belong in the main PWP folder. PWP never copies or writes dll files, so some other process must be deleting the file, however I do not have any idea of what that may be. I don't know if write-protecting (setting its attribute to read-only) the file would prevent it from being overwritten, but it might be worth a try.

Kiril Sinkel
Digital Light & Color